Recent Posts
Recent Comments
Link
06-14 19:23
Today
Total
관리 메뉴

삶 가운데 남긴 기록 AACII.TISTORY.COM

Unsupported class version number [52.0] (maximum 51.0, Java 1.7) 본문

DEV&OPS/Java

Unsupported class version number [52.0] (maximum 51.0, Java 1.7)

ALEPH.GEM 2024. 5. 10. 20:21

 

안드로이드 어플리케이션을 이클립스로 빌드 할 때

 

구글에서 SDK 26 이하 버전은 더 이상 업데이트를 해주지 않고 있습니다.

 

그래서 최소 안드로이드8.0 이상 버전으로 올려서 빌드를 해야합니다.

 

그런데

 

Unsupported class version number [52.0] (maximum 51.0, Java 1.7)

 

라고 나오면서 빌드가 되지 않습니다.

 

이 문제는 프로가드의 업데이트 문제입니다.

 

https://sourceforge.net/projects/proguard/files/proguard/

 

ProGuard Java Optimizer and Obfuscator - Browse /proguard at SourceForge.net

Runn is a modern resource and capacity planning platform that gets remote teams on the same page. Runn is best suited for project managers, operations leads, resourcing managers and other people responsible for project delivery.

sourceforge.net

 

여기에서 최신 버전 프로가드 zip 파일을 다운 받은 후 안드로이드 sdk가 설치된 경로에

 

C:\SDK설치경로\tools\proguard

 

에 압축을 풀어서 넣어 두면 됩니다.

 

그러면 Failed to load C:\SDK경로\build-tools\...\lib\dx.jar

 

오류가 나는 경우가 있습니다.

 

이것은 이클립스가 adt를 더 이상 지원하지 않기 때문에 생기는 문제입니다.

 

꼼수로 구 버전의 dx.jar 파일을 구해서 lib 폴더 안에다가 붙여넣기 한 후 빌드하면 됩니다.

 

어쩔 수 없이 이클립스를 사용하는 경우에 이렇게 조치 하면 되지만

 

결국 안드로이드 스튜디오로 넘어가긴 해야합니다.

 

구글에서 더이상 지원하지 않기 때문에요.

 

 

728x90